fix resolve Wolfram/Mathematica/lib/x86_64-linux-gnu/libfontconfig.so.1-error

 Symbol lookup error during Mathematica installation on Ubuntu 20.04

Wolfram Mathematica after upgrade to ubuntu 19.04-20.04 symbol lookup error usr/lib

For three decades, Mathematica has defined the state of the art in technical computing— and provided the principal computation environment for millions of innovators, educators, students, and others around the world.

Recently Mathematica installation on new version of Ubuntu operating system such as ubuntu 19.04 and 20.04 encountered such problem and this kind error was reported when you try to start  Mathematica.


"/usr/local/Wolfram/Mathematica/10.0/SystemFiles/FrontEnd/Binaries/Linux-x86-64/Mathematica: symbol lookup error: /lib/x86_64-linux-gnu/libfontconfig.so.1: undefined symbol"

Solution:- 

First run the following commands on your Linux terminal 

$sudo apt-get autoremove

$sudo apt-get update

$sudo apt-get -y install

$sudo dpkg --configure -a

path location of files to be rename

$cd /usr/local/Wolfram/Mathematica/11.3/SystemFiles/Libraries/Linux-x86-64/

for version 10.0

$cd /usr/local/Wolfram/Mathematica/10.0/SystemFiles/Libraries/Linux-x86-64/

sudo#mv libfreetype.so.6 libfreetype.so.6-bak

sudo#mv libz.so.1 libz.so.1-bak

Go to the MathematicaInstallationDirectory/SystemFiles/Libraries/Linux-x86-64/ in my case it's 

#/usr/local/Wolfram/Mathematica/11.3/SystemFiles/Libraries/Linux-x86-64)

Problem is specific to Wolfram Mathematica. 

I hope using this steps you will be able to solved the issue by following some of the steps from this question: 

If you are facing problem, Not able to start Mathematica on Linux Ubuntu. 

So this guide may be helpful to resolve the problem.

$sudo apt-get clean

$sudo apt-get autoclean

sudo mv libfreetype.so.6 libfreetype.so.6.bak

sudo mv libz.so.1 libz.so.1.bak

Just to test, When you try to start Mathematica right after renaming the first file, libfreetype.so.6. It may not work and show the following error:

$ mathematica

#"/usr/local/Wolfram/Mathematica/11.3/SystemFiles/FrontEnd/Binaries/Linux-x864/Mathematica:  

#/usr/local/Wolfram/Mathematica/11.3/SystemFiles/Libraries/Linux-x86-64/libz.so.1: version `ZLIB_1.2.9' not found (required by /usr/lib/x86_64-linux-gnu/libpng16.so.16"

Just rename the second file also "libz.so.1 libz.so.1", after process given here above error will disappear and resolve the problem.

Just run $ mathematica 

Previous Post
Next Post
Related Posts

0 Comments:

Follow by Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.